const regex = /<BR><B>(.*)<\/B>|= ([\w\s]+?|)$|= ([\w\s]+?|)/gum;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<BR><B>(.*)<\\\/B>|= ([\\w\\s]+?|)$|= ([\\w\\s]+?|)', 'gum')
const str = `Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> = sssssss
Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Kultura</B> = <BR><B>Kul</B> = zzzzzzzzz dstset
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}