import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<BR><B>(.*)<\\/B>|= ([\\w\\s]+?|)$|= ([\\w\\s]+?|)";
final String string = "Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> = sssssss\n\n"
+ "Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Kultura</B> = <BR><B>Kul</B> = zzzzzzzzz dstset\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}