using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"insert[\s]+into[\s]+(?<table>.*?)[\s]*\([\s]*(?<columns>.*?)[\s]*\)[\s]+values[\s]+\((?<values>.*?)[\s]*\);";
string input = @"insert into table ( a, b, c ) values ( "" insert into values (1,2,3)"",1,2.3,""a,b"" );
insert into table (ee,bb,cc) values (aa,234,""asj"",2.3);";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}