// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)insert[\s]+into[\s]+(?<table>.*?)[\s]*\([\s]*(?<columns>.*?)[\s]*\)[\s]+values[\s]+\((?<values>.*?)[\s]*\);").unwrap();
let string = "insert into table ( a, b, c ) values ( \" insert into values (1,2,3)\",1,2.3,\"a,b\" );
insert into table (ee,bb,cc) values (aa,234,\"asj\",2.3);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}