use strict;
my $str = 'insert into table ( a, b, c ) values ( " insert into values (1,2,3)",1,2.3,"a,b" );
insert into table (ee,bb,cc) values (aa,234,"asj",2.3);';
my $regex = qr/insert[\s]+into[\s]+(?<table>.*?)[\s]*\([\s]*(?<columns>.*?)[\s]*\)[\s]+values[\s]+\((?<values>.*?)[\s]*\);/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}