package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)insert[\s]+into[\s]+(?<table>.*?)[\s]*\([\s]*(?<columns>.*?)[\s]*\)[\s]+values[\s]+\((?<values>.*?)[\s]*\);`)
var str = `insert into table ( a, b, c ) values ( " insert into values (1,2,3)",1,2.3,"a,b" );
insert into table (ee,bb,cc) values (aa,234,"asj",2.3);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}