const regex = /insert[\s]+into[\s]+(?<table>.*?)[\s]*\([\s]*(?<columns>.*?)[\s]*\)[\s]+values[\s]+\((?<values>.*?)[\s]*\);/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('insert[\\s]+into[\\s]+(?<table>.*?)[\\s]*\\([\\s]*(?<columns>.*?)[\\s]*\\)[\\s]+values[\\s]+\\((?<values>.*?)[\\s]*\\);', 'gmi')
const str = `insert into table ( a, b, c ) values ( " insert into values (1,2,3)",1,2.3,"a,b" );
insert into table (ee,bb,cc) values (aa,234,"asj",2.3);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}