import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "insert[\\s]+into[\\s]+(?<table>.*?)[\\s]*\\([\\s]*(?<columns>.*?)[\\s]*\\)[\\s]+values[\\s]+\\((?<values>.*?)[\\s]*\\);";
final String string = "insert into table ( a, b, c ) values ( \" insert into values (1,2,3)\",1,2.3,\"a,b\" );\n\n"
+ "insert into table (ee,bb,cc) values (aa,234,\"asj\",2.3);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}