#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sim)(?:(?:https?)+\:\/\/+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif|bmp|webp|pna|tiff|svg))"
Local $sString = "https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg" & @CRLF & _
"src="../c624121/v624121992/3cf22/YRIx_w-QySg.png"" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/jpg/YRIx_w-QySg.jpg" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.webp" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.tiff" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.pna" & @CRLF & _
"https://pp.vk.me/c624121/v624121992/3cf22/svg/YRIx_w-QySg.svg" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")