using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:https?)+\:\/\/+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif|bmp|webp|pna|tiff|svg))";
string input = @"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg
src=""../c624121/v624121992/3cf22/YRIx_w-QySg.png""
https://pp.vk.me/c624121/v624121992/3cf22/jpg/YRIx_w-QySg.jpg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.webp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.tiff
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.pna
https://pp.vk.me/c624121/v624121992/3cf22/svg/YRIx_w-QySg.svg
";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}