use strict;
my $str = 'https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg
src="../c624121/v624121992/3cf22/YRIx_w-QySg.png"
https://pp.vk.me/c624121/v624121992/3cf22/jpg/YRIx_w-QySg.jpg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.webp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.tiff
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.pna
https://pp.vk.me/c624121/v624121992/3cf22/svg/YRIx_w-QySg.svg
';
my $regex = qr/(?:(?:https?)+\:\/\/+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif|bmp|webp|pna|tiff|svg))/simp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}