import re
regex = re.compile(r"(?:(?:https?)+\:\/\/+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif|bmp|webp|pna|tiff|svg))", flags=re.DOTALL | re.IGNORECASE | re.MULTILINE)
test_str = ("https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg\n"
"src=\"../c624121/v624121992/3cf22/YRIx_w-QySg.png\"\n"
"https://pp.vk.me/c624121/v624121992/3cf22/jpg/YRIx_w-QySg.jpg\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.webp\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.tiff\n"
"https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.pna\n"
"https://pp.vk.me/c624121/v624121992/3cf22/svg/YRIx_w-QySg.svg\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")