// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sim)(?:(?:https?)+\:\/\/+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif|bmp|webp|pna|tiff|svg))").unwrap();
let string = "https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg
src=\"../c624121/v624121992/3cf22/YRIx_w-QySg.png\"
https://pp.vk.me/c624121/v624121992/3cf22/jpg/YRIx_w-QySg.jpg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.webp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.tiff
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.pna
https://pp.vk.me/c624121/v624121992/3cf22/svg/YRIx_w-QySg.svg
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}