using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)(?<!\\)((?:\\\\)*)(\!\=|(?<!\!|\<|\>)=|\<\=|\>\=)(.+)$";
string substitution = @"[$1$2] $3 [$4]";
string input = @"name=toto
tat\=a
bla\bla=tor
blood\\=orange
wrong\\\=cops
right\\\\=escaping
extrem\\\\\=slash
hoho\\\\\\=ho
is\\\\\\\=magic
noend=
dou=bl=equal
ma\=tche!=operation
is\\!=not
is<=inferior
is>=superior
tha>t=isno<t
-----
^(.+)((?<!\\)=)(.+)$";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}