import Foundation
let pattern = #"^(.+)(?<!\\)((?:\\\\)*)(\!\=|(?<!\!|\<|\>)=|\<\=|\>\=)(.+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
name=toto
tat\=a
bla\bla=tor
blood\\=orange
wrong\\\=cops
right\\\\=escaping
extrem\\\\\=slash
hoho\\\\\\=ho
is\\\\\\\=magic
noend=
dou=bl=equal
ma\=tche!=operation
is\\!=not
is<=inferior
is>=superior
tha>t=isno<t
-----
^(.+)((?<!\\)=)(.+)$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$1$2] $3 [$4]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)