import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+)(?<!\\\\)((?:\\\\\\\\)*)(\\!\\=|(?<!\\!|\\<|\\>)=|\\<\\=|\\>\\=)(.+)$";
final String string = "name=toto\n"
+ "tat\\=a\n"
+ "bla\\bla=tor\n"
+ "blood\\\\=orange\n"
+ "wrong\\\\\\=cops\n"
+ "right\\\\\\\\=escaping\n"
+ "extrem\\\\\\\\\\=slash\n"
+ "hoho\\\\\\\\\\\\=ho\n"
+ "is\\\\\\\\\\\\\\=magic\n"
+ "noend=\n\n"
+ "dou=bl=equal\n"
+ "ma\\=tche!=operation\n"
+ "is\\\\!=not\n"
+ "is<=inferior\n"
+ "is>=superior\n"
+ "tha>t=isno<t\n\n"
+ "-----\n"
+ "^(.+)((?<!\\\\)=)(.+)$";
final String subst = "[$1$2] $3 [$4]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}