import re
regex = re.compile(r"^(.+)(?<!\\)((?:\\\\)*)(\!\=|(?<!\!|\<|\>)=|\<\=|\>\=)(.+)$", flags=re.MULTILINE)
test_str = ("name=toto\n"
"tat\\=a\n"
"bla\\bla=tor\n"
"blood\\\\=orange\n"
"wrong\\\\\\=cops\n"
"right\\\\\\\\=escaping\n"
"extrem\\\\\\\\\\=slash\n"
"hoho\\\\\\\\\\\\=ho\n"
"is\\\\\\\\\\\\\\=magic\n"
"noend=\n\n"
"dou=bl=equal\n"
"ma\\=tche!=operation\n"
"is\\\\!=not\n"
"is<=inferior\n"
"is>=superior\n"
"tha>t=isno<t\n\n"
"-----\n"
"^(.+)((?<!\\\\)=)(.+)$")
subst = "[$1$2] $3 [$4]"
result = regex.sub(subst, test_str)
if result:
print(result)