const regex = /^(.+)(?<!\\)((?:\\\\)*)(\!\=|(?<!\!|\<|\>)=|\<\=|\>\=)(.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+)(?<!\\\\)((?:\\\\\\\\)*)(\\!\\=|(?<!\\!|\\<|\\>)=|\\<\\=|\\>\\=)(.+)$', 'gm')
const str = `name=toto
tat\\=a
bla\\bla=tor
blood\\\\=orange
wrong\\\\\\=cops
right\\\\\\\\=escaping
extrem\\\\\\\\\\=slash
hoho\\\\\\\\\\\\=ho
is\\\\\\\\\\\\\\=magic
noend=
dou=bl=equal
ma\\=tche!=operation
is\\\\!=not
is<=inferior
is>=superior
tha>t=isno<t
-----
^(.+)((?<!\\\\)=)(.+)\$`;
const subst = `[$1$2] $3 [$4]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);