#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!.*(.)\1{2})[a-z0-9]*$"
Local $sString = "aab" & @CRLF & _
"aaa" & @CRLF & _
"abc" & @CRLF & _
"aabbcc" & @CRLF & _
"aabbbcc" & @CRLF & _
"aa22cc" & @CRLF & _
"aa222cc" & @CRLF & _
"xxxxxxxxxxx" & @CRLF & _
"111111111" & @CRLF & _
"xx11xx11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")