using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(.)\1{2})[a-z0-9]*$";
string input = @"aab
aaa
abc
aabbcc
aabbbcc
aa22cc
aa222cc
xxxxxxxxxxx
111111111
xx11xx11";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}