$re = '/^(?!.*(.)\1{2})[a-z0-9]*$/mi';
$str = 'aab
aaa
abc
aabbcc
aabbbcc
aa22cc
aa222cc
xxxxxxxxxxx
111111111
xx11xx11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);