const regex = /^(?!.*(.)\1{2})[a-z0-9]*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*(.)\\1{2})[a-z0-9]*$', 'gmi')
const str = `aab
aaa
abc
aabbcc
aabbbcc
aa22cc
aa222cc
xxxxxxxxxxx
111111111
xx11xx11`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}