re = /^(?!.*(.)\1{2})[a-z0-9]*$/mi
str = 'aab
aaa
abc
aabbcc
aabbbcc
aa22cc
aa222cc
xxxxxxxxxxx
111111111
xx11xx11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end