import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(.)\\1{2})[a-z0-9]*$";
final String string = "aab\n"
+ "aaa\n"
+ "abc\n"
+ "aabbcc\n"
+ "aabbbcc\n"
+ "aa22cc\n"
+ "aa222cc\n"
+ "xxxxxxxxxxx\n"
+ "111111111\n"
+ "xx11xx11";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}