using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\_\WQOIqoi]+";
string input = @"~!@#$%^&*()_+
`1234567890-=
qwertyuiop[]\
QWERTYUIOP{}|
asdfghjkl;'
ASDFGHJKL:""
zxcvbnm,./
ZXCVBNM<>?
(Muḥammad ibn Mūsā al-Khwārizmī's c. 825 book On the Calculation with Hindu Numerals)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}