import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\_\\WQOIqoi]+";
final String string = "~!@#$%^&*()_+\n"
+ "`1234567890-=\n"
+ " qwertyuiop[]\\\n"
+ " QWERTYUIOP{}|\n"
+ "asdfghjkl;'\n"
+ "ASDFGHJKL:\"\n"
+ "zxcvbnm,./\n"
+ "ZXCVBNM<>?\n\n"
+ "(Muḥammad ibn Mūsā al-Khwārizmī's c. 825 book On the Calculation with Hindu Numerals)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}