re = /[\_\WQOIqoi]+/m
str = '~!@#$%^&*()_+
`1234567890-=
qwertyuiop[]\\
QWERTYUIOP{}|
asdfghjkl;\'
ASDFGHJKL:"
zxcvbnm,./
ZXCVBNM<>?
(Muḥammad ibn Mūsā al-Khwārizmī\'s c. 825 book On the Calculation with Hindu Numerals)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end