import re
regex = re.compile(r"[\_\WQOIqoi]+", flags=re.MULTILINE)
test_str = ("~!@#$%^&*()_+\n"
"`1234567890-=\n"
" qwertyuiop[]\\\n"
" QWERTYUIOP{}|\n"
"asdfghjkl;'\n"
"ASDFGHJKL:\"\n"
"zxcvbnm,./\n"
"ZXCVBNM<>?\n\n"
"(Muḥammad ibn Mūsā al-Khwārizmī's c. 825 book On the Calculation with Hindu Numerals)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")