package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\_\WQOIqoi]+`)
var str = `~!@#$%^&*()_+
\`1234567890-=
qwertyuiop[]\
QWERTYUIOP{}|
asdfghjkl;'
ASDFGHJKL:"
zxcvbnm,./
ZXCVBNM<>?
(Muḥammad ibn Mūsā al-Khwārizmī's c. 825 book On the Calculation with Hindu Numerals)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}