$re = '/[\_\WQOIqoi]+/m';
$str = '~!@#$%^&*()_+
`1234567890-=
qwertyuiop[]\\
QWERTYUIOP{}|
asdfghjkl;\'
ASDFGHJKL:"
zxcvbnm,./
ZXCVBNM<>?
(Muḥammad ibn Mūsā al-Khwārizmī\'s c. 825 book On the Calculation with Hindu Numerals)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);