import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\/\\/ .*$";
final String string = "fdsafda\n"
+ "gsdf\n"
+ "fdsasdf // \n"
+ "sdfgsdf\n"
+ "// gfdsgfdsg\n"
+ "gsdfgsdf\n"
+ "sagsdfg fdsgsdfgsdf gfdsgsdgsdfg fdsz \n"
+ "fdsafsda // fdsafsafsda\n\n"
+ "Te się nie łapią:\n"
+ "//fdfdfdf fd f\n"
+ "fdsfdsa //fsdafdsa\n"
+ "fdsafdsa fdsafsda//fdsafdas";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}