re = /^.*\/\/ .*$/m
str = 'fdsafda
gsdf
fdsasdf //
sdfgsdf
// gfdsgfdsg
gsdfgsdf
sagsdfg fdsgsdfgsdf gfdsgsdgsdfg fdsz
fdsafsda // fdsafsafsda
Te się nie łapią:
//fdfdfdf fd f
fdsfdsa //fsdafdsa
fdsafdsa fdsafsda//fdsafdas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end