$re = '/^.*\/\/ .*$/m';
$str = 'fdsafda
gsdf
fdsasdf //
sdfgsdf
// gfdsgfdsg
gsdfgsdf
sagsdfg fdsgsdfgsdf gfdsgsdgsdfg fdsz
fdsafsda // fdsafsafsda
Te się nie łapią:
//fdfdfdf fd f
fdsfdsa //fsdafdsa
fdsafdsa fdsafsda//fdsafdas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);