# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*),([^,]+)$/$1$2/g;t' <<< "INSERT INTO Customers (CustomerName, ContactName, Address, ) VALUES (\\"Cardinal\\", \\"Tom B. Erichsen\\", \\"Skagen 21\\",)"