$re = '/(.*),([^,]+)$/';
$str = 'INSERT INTO Customers (CustomerName, ContactName, Address, ) VALUES (\\"Cardinal\\", \\"Tom B. Erichsen\\", \\"Skagen 21\\",)';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;