use strict;
my $str = 'INSERT INTO Customers (CustomerName, ContactName, Address, ) VALUES (\\"Cardinal\\", \\"Tom B. Erichsen\\", \\"Skagen 21\\",)';
my $regex = qr/(.*),([^,]+)$/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";