#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^(?:" & @CRLF & _
" [0369] |" & @CRLF & _
" (?:" & @CRLF & _
" [147]" & @CRLF & _
" (?:[147][0369]*[258]|[0369])*" & @CRLF & _
" [258]" & @CRLF & _
" ) |" & @CRLF & _
" (?:" & @CRLF & _
" [258]" & @CRLF & _
" (?:[258][0369]*[147]|[0369])*" & @CRLF & _
" [147]" & @CRLF & _
" )" & @CRLF & _
")+$"
Local $sString = "0" & @CRLF & _
"3" & @CRLF & _
"6" & @CRLF & _
"9" & @CRLF & _
"12" & @CRLF & _
"15" & @CRLF & _
"18" & @CRLF & _
"21" & @CRLF & _
"99" & @CRLF & _
"102" & @CRLF & _
"534" & @CRLF & _
"999" & @CRLF & _
"" & @CRLF & _
"998" & @CRLF & _
"2" & @CRLF & _
"4" & @CRLF & _
"101" & @CRLF & _
"17" & @CRLF & _
"19" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")