const regex = /^(?:
[0369] |
(?:
[147]
(?:[147][0369]*[258]|[0369])*
[258]
) |
(?:
[258]
(?:[258][0369]*[147]|[0369])*
[147]
)
)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:
[0369] |
(?:
[147]
(?:[147][0369]*[258]|[0369])*
[258]
) |
(?:
[258]
(?:[258][0369]*[147]|[0369])*
[147]
)
)+$', 'gm')
const str = `0
3
6
9
12
15
18
21
99
102
534
999
998
2
4
101
17
19
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}