package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:
[0369] |
(?:
[147]
(?:[147][0369]*[258]|[0369])*
[258]
) |
(?:
[258]
(?:[258][0369]*[147]|[0369])*
[147]
)
)+$`)
var str = `0
3
6
9
12
15
18
21
99
102
534
999
998
2
4
101
17
19
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}