$re = '/^(?:
[0369] |
(?:
[147]
(?:[147][0369]*[258]|[0369])*
[258]
) |
(?:
[258]
(?:[258][0369]*[147]|[0369])*
[147]
)
)+$/xm';
$str = '0
3
6
9
12
15
18
21
99
102
534
999
998
2
4
101
17
19
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);