# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(?:
[0369] |
(?:
[147]
(?:[147][0369]*[258]|[0369])*
[258]
) |
(?:
[258]
(?:[258][0369]*[147]|[0369])*
[147]
)
)+$
"""
test_str = ("0\n"
"3\n"
"6\n"
"9\n"
"12\n"
"15\n"
"18\n"
"21\n"
"99\n"
"102\n"
"534\n"
"999\n\n"
"998\n"
"2\n"
"4\n"
"101\n"
"17\n"
"19\n\n\n")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.