use strict;
my $str = '0
3
6
9
12
15
18
21
99
102
534
999
998
2
4
101
17
19
';
my $regex = qr/^(?:
[0369] |
(?:
[147]
(?:[147][0369]*[258]|[0369])*
[258]
) |
(?:
[258]
(?:[258][0369]*[147]|[0369])*
[147]
)
)+$/xmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}