#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(\bpublic\b)\s|(\bprivate\b)\s|(\bclass\b)\s(\b\w+\b)(?:\(.*\)))"
Local $sString = "public class Something()" & @CRLF & _
"private class SomethingElse()" & @CRLF & _
"public class Something(Parameter parameter)" & @CRLF & _
"private class SomethingElse(One one, Two two)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")