import re
regex = re.compile(r"(?:(\bpublic\b)\s|(\bprivate\b)\s|(\bclass\b)\s(\b\w+\b)(?:\(.*\)))")
test_str = ("public class Something()\n"
"private class SomethingElse()\n"
"public class Something(Parameter parameter)\n"
"private class SomethingElse(One one, Two two)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")