re = /(?:(\bpublic\b)\s|(\bprivate\b)\s|(\bclass\b)\s(\b\w+\b)(?:\(.*\)))/
str = 'public class Something()
private class SomethingElse()
public class Something(Parameter parameter)
private class SomethingElse(One one, Two two)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end