use strict;
my $str = 'public class Something()
private class SomethingElse()
public class Something(Parameter parameter)
private class SomethingElse(One one, Two two)';
my $regex = qr/(?:(\bpublic\b)\s|(\bprivate\b)\s|(\bclass\b)\s(\b\w+\b)(?:\(.*\)))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}