import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\\bpublic\\b)\\s|(\\bprivate\\b)\\s|(\\bclass\\b)\\s(\\b\\w+\\b)(?:\\(.*\\)))";
final String string = "public class Something()\n"
+ "private class SomethingElse()\n"
+ "public class Something(Parameter parameter)\n"
+ "private class SomethingElse(One one, Two two)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}