$re = '/(?:(\bpublic\b)\s|(\bprivate\b)\s|(\bclass\b)\s(\b\w+\b)(?:\(.*\)))/';
$str = 'public class Something()
private class SomethingElse()
public class Something(Parameter parameter)
private class SomethingElse(One one, Two two)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);