# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n\n1. Discover Your Next Adventure: Shop SUVs at Zylker Automobiles.\n2. Ready for the Road Ahead: Explore SUVs at Zylker Automobiles.\n3. Conquer the Road: Find Your Ideal SUV at Zylker Automobiles.\n4. Embark on Your Next Journey: Choose Your SUV at Zylker Automobiles.\n5. Unleash Your Inner Explorer: Find Your Perfect SUV at Zylker Automobiles./ /g;t' <<< "Don't change this
Do change that
(two newlines) but don't change this
because three newlines follow"