#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\n\n1. Discover Your Next Adventure: Shop SUVs at Zylker Automobiles.\n2. Ready for the Road Ahead: Explore SUVs at Zylker Automobiles.\n3. Conquer the Road: Find Your Ideal SUV at Zylker Automobiles.\n4. Embark on Your Next Journey: Choose Your SUV at Zylker Automobiles.\n5. Unleash Your Inner Explorer: Find Your Perfect SUV at Zylker Automobiles."
Local $sString = "Don't change this" & @CRLF & _
"Do change that" & @CRLF & _
"" & @CRLF & _
"(two newlines) but don't change this" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"because three newlines follow"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)